
 

Zimbra Collaboration Suite Connector for Outlook
With the Zimbra Collaboration Suite Connector for Outlook, users can use 
Microsoft® Outlook® 2003 to access the Zimbra Collaboration Suite server 
and synchronize data to/from Outlook for offline use. The Zimbra 
Collaboration Suite Connector for Outlook is a MAPI service provider that is 
installed on users’ computers.

Important:  Client computers must have Microsoft Office Outlook 2003 SP1 or 
later installed. See Microsoft’s support article http://support.microsoft.com/
?id=823633.

Email messages, contact lists, and personal calendars are synchronized to 
the Outlook 2003 client. Zimbra Collaboration Suite server-side configuration 
for accounts is enforced for Outlook users. 

Downloading ZCS Connector for Outlook Install Program
The ZCS Connector for Outlook .msi file and user instructions can be 
downloaded from the Administration Console, Downloads area. The install 
program for the ZCS Connector for Outlook is in the Windows Installer .msi 
format so that it can be easily deployed to individual computers using your 
group policy software deployment process, or you can copy the .msi file to a 
directory that users can access and instruct your users to download the file 
directly. 

ZCS Connector for Outlook Install Program
When the ZCS Connector for Outlook is installed, the server name, port, and 
whether to use a secure connection must be set for every user. Users enter 
this information when they create their profile. 

Optionally, administrators can modify the ZCS Connector for Outlook .msi file 
and add the server, port, and connection information to the install script. If the 
.msi file is customized, end users only need to enter their email address and 
password. 
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Optional step to modify the ZCS Connector for Outlook .msi file

To modify the .msi file, Zimbra created a Java Script file that runs under the 
Windows Scripting Host. This file, called ZmCustomizeMSI.js, can be found in 
the Zimbra download directory on the administration console. 

1. Copy the ZmCustomizeMSI.js file and the ZCS Connector for Outlook .msi 
file to a computer running the Windows platform. 

Note:  The ZCS Connector for Outlook .msi file name is different from the 
example shown here. Please note the exact file name when you download 
it.

2. Open the Windows Command Prompt and go to the directory were the 
ZmCustomizeMSI.js file is saved. For example, if it is saved in the temp 
folder on your C drive, you would type cd c:\temp. 

3. From the command line, type, all on one line:

cscript ZmCustomizeMSI.js <path/msi-filename> <servername> <port> <1 | 
0>//nologo

Press Enter and the ZCS Connector for Outlook .msi file is modified. 

The cscript command includes the following:

• Name of the .js file (ZmCustomizeMSI.js).

• Directory path and the ZCS Connector for Outlook .msi file name. Verify 
exact name of file. (path/msi-filename)

• Zimbra server domain name (DNS) to be configured in the .msi file. 
(servername)

• Port number to be configured. For non-secured connections, the default 
is 80. For secured connection, the default is 443. Your configuration can 
be different. (port)

• Whether User Secure Connection should be checked. Enter 1 for the 
secure connection using a HTTPS connection or enter 0 to use a HTTP 
connection. (1 | 0)

Example:

cscript ZmCustomizeMSI.js ZimbraOlkConnector.msi server.example.com 443 1
//nologo

4. To verify that the modification is correct, you can run the .msi installer and 
create a dummy profile. The Zimbra Server Configuration Settings dialog 
should include the server name, server port, and the check box marked/
unmarked.

This modified .msi file should be saved to a directory that users can access 
to download the file to their computers.
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Steps to Install the ZCS Connector for Outlook
It only takes a few minutes for users to install the ZCS Connector for Outlook 
on their computers and configure the connection to the Zimbra server. The 
user’s Zimbra account must be created, but no specific changes are required 
on the Zimbra server. Installing the Connector for Outlook creates a mail 
profile named Zimbra and designates it as the default profile.

If you do not modify the .msi file as described in “Optional step to modify the 
ZCS Connector for Outlook .msi file” on page 94, users will need to know the 
following in order to complete the installation:

• Zimbra server domain name (DNS).

• Which server port is used. For non secured connections, the default is 80. 
For secured connection, the default is 443. Your configuration can be 
different.

• Whether to check Use Secure Connection (SSL). This box is checked to 
establish a secure connection to that port.

• Their complete email address and their email password.

The following describes the installation and configuration steps that are 
performed on each computer. User instructions can be downloaded from the 
administration console Download page. This one page pdf file explains how to 
install and configure the ZCS Connector for Outlook. Save this pdf file to a 
directory that user can access before they install the ZCS Connector for 
Outlook.

1. When the MSI installer starts, a Welcome dialog displays. 

2. Next, the End-user License Agreement displays. Users must read the 
license agreement and click I accept the terms in the License Agreement. 
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3. Next, the installer is ready to install the Zimbra Service Provider on the 
computer. 

4. The dialog displays the progress bar. When the installation is complete, 
Installation Complete dialog displays.

5. Users open Outlook, and if you did not modify the .msi file, complete the 
Zimbra Server Configuration Settings dialog as follows.

• Server Name. This is the Zimbra server domain name (DNS).

• Server Port. Enter the port number for the server. For non secured 
connections, the standard port is 80. For secured connection, the 
standard port is 443. Your configuration can be different.

• Use Secure Connection. Check this box to establish a secure connection 
to that port.

6. Users enter their email address in Email address. The address should be 
entered as name@domain.com and their Zimbra account password in 
Password.

7. They click OK and the installation and configuration of the ZCS Connector 
for Outlook is complete. The Zimbra profile is created.

Final Steps - Initial Sync
Users can now log on and use Outlook. If users did not have a previous 
Zimbra account, (i.e. no email, address books or calendar activities), the first 
time they work within Outlook’s mail, calendar or contacts folders, Outlook 
automatically syncs to the Zimbra server.

If users have been using the Zimbra Web Client and have email, address 
books with contacts, and calendar appointments on the Zimbra server, 
Outlook will need to be synchronized to the Zimbra server. To synchronize, 
users click Tools>Send/Receive. The initial synchronization can take a few 
minutes. If the default zimbra profile was created, the synchronized files are 
saved in the zimbra.zdb file located in the user’s Local Settings\Application 
Data\Microsoft\Outlook folder.

Note:   You can create your profile. the profile name will have the .zdb 
extension.

After the initial sync, Send/Receive updates Outlook and the Zimbra server 
with changes made since the last sync.

Repairing ZCS Connector for Outlook
You can use the same version of the Zimbra Collaboration Suite Connector for 
Outlook MSI file to repair the ZCO software on individual computers. When the 
.msi file is opened after the ZCS Connector for Outlook is installed, it 
automatically opens with the options to repair the connector or to remove the 
software.
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• Repair will reinstall the software again.

• Remove the Outlook Connector removes all components. Note: you can 
also remove the ZCS Connector for Outlook from the computer’s Control 
Panel, Add or Remove directory.

Removing the Connector for Outlook does not remove the profile or .zdb 
files. Users will need to delete these items manually. 

Resolving Mailbox Sync Problems
In the event that a user’s mailbox cannot receive new mail, becomes out-of-
sync, or his .zdb file becomes corrupted, you can either:

• Choose to force an initial sync of the user’s mailbox. In order to do this, you 
can either have the user create another profile, open Outlook, and click 
Tools>Send/Receive to sync to the Zimbra server. 

• Have the user delete the existing .zdb file and then click Tools> Send/
Receive. This deletes all data on the user’s computer and recreates the 
mailbox from the data that is on the Zimbra server, but keeps the same 
profile.

In some cases, it may be necessary to uninstall the .msi file, delete the profile 
and zdb file and start over. 

Important:  When the Zimbra server is restored from a Zimbra backup 
session, users should delete any .zdb files in folder and resync Outlook to the 
Zimbra server.

Removing the ZCS Connector for Outlook files
To remove the ZCS Connector from Outlook completely from the computer, 
delete the .zdb file and the user’s profile, and uninstall the ZCS Connector 
.msi file.

Note:   Users can use the Outlook File>Import/Export feature to save their 
tasks or other Outlook folders that do not sync with the Zimbra server. The 
files can be imported back into Outlook.

1. Users must delete the .zdb file.The zdb file includes all the Outlook data 
from the Zimbra server. The file is usually in the user’s Local Setting\/
Application Data\ Microsoft\ Outlook folder.

Note:  If they cannot see this file, users should change the Folder Options/
View to “Show hidden files and folders”.

2. Users must delete their Zimbra profile. If users accept the defaults when 
they installed the ZCS Connector for Outlook, a profile called Zimbra was 
created. To delete this file:

a. Open to the Control Panel and select Mail.
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b. Click Show Profiles. The General tab lists all the profiles on the 
computer. 

c. Select the Zimbra profile and click Remove.

d. Click OK.

5. Go to the Control Panel, select Add and Remove Programs and remove the 
ZCS Connector for Outlook program.

Important:  If the Connector for Outlook is re-installed and the .zdb file was 
not deleted, Outlook cannot sync with the Zimbra server, because the Zimbra 
profile will use the existing .zdb file rather than create a new file.

Troubleshooting Options
If the Outlook client is not synchronizing with the Zimbra server or if Outlook is 
not working correctly, several options are available to troubleshoot the 
problem.

• Review the user’s Sync Issues mail folder for errors.

• If the initial sync did not work, run the .msi file again and select Repair to 
see if reinstalling the ZCS Connector to Outlook resolves the problem. 

• If Outlook closes unexpectedly, i.e. with the warning “Outlook ...needs to 
close,” generate core dumps for Outlook. Go to the Zimbra Wiki CoreDump 
page for directions. The core dump shows what Outlook was doing at the 
time of the crash. This file should be sent to Zimbra support.

• If Outlook is hanging, or behaving strangely, run the Logging Control tool 
that is installed when the Connector for Outlook was installed. See “Using 
Logging Control for Troubleshooting” on page 99. This file should be sent to 
Zimbra support. 

• Remove the Zimbra Connector for Outlook .msi file, delete the zdb file and 
the profile, and reinstall.

Reviewing Sync Issues Folders

When ZCS Connector for Outlook is installed, a Sync Issues mail folder with 
subfolders is created in their mailbox. If errors are found when Outlook syncs 
with the Zimbra server, message with attachments are automatically added to 
these folders. Users can tell when messages are in these folders if the folder 
is bold and the number of unread messages is displayed. 

If users are having problems using Outlook and continuously receiving errors, 
the messages in these folders should be forwarded to sync_issues@ 
zimbra.com. These messages are created to help Zimbra technical support 
and engineering debug and fix errors.
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Using Logging Control for Troubleshooting 

If users encounter problems when logged on to Outlook, you can have them 
enable the logging control tool to log errors and events that occur while they 
are using Outlook. This log then can be sent to Zimbra for analysis. 

ZCOLogCtl.exe is installed when ZCS Connector for Outlook is installed. This 
logging control tool is in the \Program files\common files\system\msmapi\1033 
directory. When users encounter problems with synchronization, not receiving 
their mail, system crashes, or other unusual behavior, you should direct users 
to open this file and enable logging in order to log internal API calls and 
communication between Outlook and the Zimbra Server. The default log file 
size is 10 megabytes, but you can increase this when necessary. When the 
size of the log reaches the limit, the current log is set aside and a second log is 
created, therefore two logs of up to the maximum log size can be generated.

Important: After enabling logging from the ZCS Outlook Logging Control 
dialog, users must restart Outlook before errors and event can be logged.

When users restart Outlook, all their activities are logged. Users should 
attempt to recreate activities that are causing the problems. When the problem 
has been recreated, send the log files to Zimbra. Open the ZCS Connector for 
Outlook Logging Control .exe again and click Send Log to Zimbra. 

Note:   The Enable Logging should be unchecked to disable logging when not 
being used for troubleshooting. If logging is on continuously, performance may 
be affected. Outlook must be restarted when you make changes with the 
ZCOLogCtl.exe file.

Finding Previous Outlook Profiles after ZCO Installation

Installing the connector does not remove any email accounts. It creates a 
separate new mail profile, by default called zimbra, which does not conflict 
with any existing profiles/accounts. To see existing account profiles, navigate 
to Start>ControlPanel>Mail>Show Profiles. 
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Zimbra Feature Differences for Outlook Users
Zimbra Collaboration Suite offers account configuration by Class of Service 
and by account. When the client uses Outlook, many of the features and 
options configured for the Zimbra account are not enforced in Outlook. Only 
restrictions that are controlled by the server are enforced. 

Users can configure their own Outlook preferences. These are not 
synchronized with the Zimbra server.

Zimbra COS features and Global Settings that are enforced include the 
following:

• Account quotas. Users can use Outlook Archiving to save files to their 
computer to prevent going over their quota limit. Archiving removes the 
messages from the Zimbra server.

• Password rules including password length, age, history

• Address book size limit

• GAL access

• Session token lifetime

• Server Pool set up

• Email message lifetime

• Trash and spam message lifetime 

• Reject messages with specified attachment extension. You cannot disable 
attachment viewing.

• Anti-spam and anti-virus rules

When you view an account’s mailbox from the administration console, the 
view is from the Zimbra Web Client and may not contain files in Outlook that 
have not been synchronized. 

Note:   When items are archived in Outlook (Outlook auto archive or 
manually), the items are removed from the Zimbra server.

In addition, the following Zimbra features do not work in Outlook.

• The Outlook Rules and Alerts feature does not work with the Zimbra server. 
But, if users created filter rules from the Zimbra Web Client, they are 
enforced. Users cannot use Outlook to view or change these rules. 

• Out of Office Reply is not available from Outlook. Users can log on to the 
Zimbra Web Client to set up and turn off their out-of-office alerts.

• Search folders created in the Zimbra Web Client do not synchronize to 
Outlook.
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